Excel, выбор фамилий из списка, используя элемент “флажок”.

Excel флажок

В статье Наряд допуск за 30 секунд я поделился бланком наряда-допуска в Excel, в котором предусмотрено добавление членов бригады в список, просто ставя галочки напротив фамилий. В Excel этот элемент называется “Флажок”. На данный момент статья полностью переписана, и элемент “Флажок” там больше не используется, но, думаю, данная информация может быть полезна и в других ситуациях. Так как добавление фамилий по флажку применимо не только при составлении наряда-допуская на производство работ в электроустановках, но и во многих других документах, пошагово опишу, как я это делал. Все картинки в тексте кликабельны.

Прежде всего отмечу, что все листы/таблицы/графики, не отображаемые в конечном документе, но необходимые для написания и нормальной работы формул Excel, я называю служебными.

 

Шаг 1. Создание документа.

Создадим новый документ Excel, и заполним список фамилий. Для этого можно отвести место на этом же листе, либо создать служебный лист, специально отведенный для таких списков. Для удобства, я сделаю все на одном листе.

Фамилии членов бригады

Служебная таблица будет состоять из двух столбцов: “Истина/ложь” и “Фамилии”. На эти две графы будет ссылаться будущая формула.

таблица истина/ложь

 

Шаг 2. Элемент управления “флажок”.

Для этого на вкладке “Разработчик” выбираем пункт “Вставить” и нажимаем на интересующий элемент.

вставить элемент управления флажок

 

Сразу же растяните его на требуемую ширину.

Excel Флажок

Вместо “Флажок 1” впишите первую фамилию из списка.

Шаг 3. Связываем этот элемент с таблицей.

Для этого нажимаем правую кнопку мыши и выбираем пункт “Формат объекта”

связь флажка с ячейкой 2

 

Появится окно для связи флажка с ячейкой. Жмем выделенный элемент, затем на первую ячейку в служебной таблице. Жмем два раза Enter.

связь с ячейкой

 

Теперь при нажатии на флажок, в таблице должно появляться “ИСТИНА”, если его снять, то “ЛОЖЬ”. Эти свойства будут нужны нам для написания формул.

Excel ложь

Excel истина

 

Шаг 4. Пишем формулу.

Теперь в служебную таблицу, графу “Фамилии” вписываем формулу такого вида

=ЕСЛИ(D2=ИСТИНА;G1;””)

Эта формула означает, что если в ячейке D2 будет значение “ИСТИНА” (галочка стоит), то в ячейку E2 вставится информация из ячейки G1.

Если в ячейке D2 будет значение “ЛОЖЬ” (галочка снята), то ячейка E2 будет пустой.

Эти шаги повторяем для каждой фамилии из списка.

 

 

Шаг 5. Создание списка в ячейке

Для того, чтобы в определенной ячейке (список членов бригады) отобразить фамилии одну за другой, нужно в ней написать формулу типа

=E2&E3&E4

Она означает, что в ячейку будут вставляться фамилии, выбранные галочками, одна за другой. Знак “&” в формуле позволяет ставить одно за другим значения из разных ячеек.

На этом все. если остались вопросы или предложения, пишите в комментариях, либо через Форму обратной связи.


Если статья была Вам полезна, поделитесь ей со своими друзьями:

Вы можете оставить комментарий, или трекбек со своего сайта.

Оставьте комментарий

Яндекс.Метрика